Thursday, April 10, 2008

ComCast? Take Notes.

Yesterday was the much anticipated ATT install. I was both excited and nervous. Part of me was actually scared silly that they would get here and something would prevent the install ( old lines, noise in the lines, something stupid).

I had an appointment for the install to begin between 8 and 10 am. At 8 am the tech called to check and make sure I was expecting him and to tell me he was going to be there in about 20 minutes. He showed up about 24 minutes after that. He came in the office and the first thing he did was slip little boot covers over his shoes to prevent tracking mud into the house. It was overkill, but it was a really nice gesture. It was not overkill later when he was out in my muddy yard doing the outside work and then came back in the house. There was not a bit of dirt or a track when they left. Maybe I need a box of those hanging at the doors for all the kids this spring?

I walked him through the house, explained what I was hoping to get, what our current setup was, etc. He boggled a little at the number of computers in the house. He was a little concerned about the fact that I wanted one of the settop boxes hooked up to my computer, not a TV ( he had only done 2 before) and when I told him some of my computers were Linux, he admitted he had no idea what that was or how it worked. They normally check every computer ( wired and wireless) for connectivity before they leave. I told him I was not expecting that, or that he re-configure the wireless on my linux boxes. As long as I had one computer talking to the wireless, I knew their part was running correctly, the rest was my responsibility to reset. And so he left to go do the outside work first and would be back in after a bit. After a while, he was joined by a fellow tech and they finished up the install together in a team fashion. They worked well together, they did not in any way mind me getting into the middle of what they were doing and asking questions (I am the sys and network admin at home, if they did not tell me, I would have to tear it apart later to understand it) and they were UberPolite.

I was told by ATT corporate that the install would take 5 to 8 hours. I found out later that they had a personal goal to get me finished in 3. They missed it by 40 minutes, mostly because I interrupted them, asked questions and slowed them down. But they never got impatient or tried to rush me through anything. We ran into some snags trying to get the settop box configured with SageTV software, but again- that was my weird add-on, and not really their responsibility. We got to proof of a signal coming through to the computer, and I let them go-- letting them know that debugging the rest of it was my problem, not theirs. They encouraged me to call tier 2 support for assistance, if I needed it. ( I have debugged it as far as getting WinTV to work via composite input on my own, but would like to get to the point of using the able input with the software able to do channel changes and use it as a PVR. But that is all candy icing--and with my Buffalo drive blown up, I have no place to record to right now, anyway......)

After a long philosophical break with Sam, I decided my mind needed less challenging things to work on, so I started exploring the web management tools ( I can set shows to record on my DVR via a web interface? Cool!) and set up sub-accounts. You get 10 sub-accounts ( which makes a total of 11 accounts with the main), so everyone in the family will get one- plus some left over for fun stuff. Plus, in starting to explore the TV Channels, I noted that ATT has added some interactive channels.. including one that was supposed to be able to display my Flickr photos on the TV- I needed to figure out how to configure that one, and I needed to locate the pop info on my main email, so I could add it to gmail and pull my email from a single interface. Lots of little silly configuration stuff that should not take too many brain cells.

I started with the sub accounts- at least for Ogre. I was going to disable Comcast, which meant his email accounts would be dead, unless I got him set up and running first. I went to the web page and went through the form. ATT is BIG on security, they have security prompts that they call offline ( which I set over the phone when the account was set up) and online ( which I set up on the web page- traditional prompt and response type questions). You had to use both sets of data to set up a sub account. I clicked the "submit" button and got an error. " Partner returns data error". Hmm... maybe I had typed something in wrong? I retyped my security answers to avoid typos. Same error. I sat and stared at the page. I punched submit again. Same error. Hrmmm.. Knowing that insanity is doing the same thing over and over again and expecting different results ( unless you are a quantum physicist), I decided to call tech support. I had a sneaking suspicion. One of my offline prompts was a 4 digit numerical pin. But one was alpha chars. What if they person at the other end had a typo? I had not thought to check it when she input it.

1-800-288-2020.

2 minutes to navigate through the voice prompts to a human being. I explained my problem, my error and what I suspected was wrong. She ran me through all the verification prompts and challenges. I proved I was really me. She checked and Yes, sure enough, their was a typo. She fixed it. She stayed on the line while I filled in the form again and hit submit. Same error. Hrmm.. She looked something up in her KB. She asked permission to put me on hold for no more than 10 minutes. I agreed. In the meantime, I started poking around on the website to figure out how to configure my Flickr. I found the link , but before I could start, she was back. (on hold this time- 4 minutes). She apologized and told me she had to transfer me to the next level of support to help with this. Could she put me on hold for no more than 10 minutes while she got the next level of support on line? Sure. I navigated on the web to the link to configure my Flickr. Ahh, it was a simple "associate this ID with your Flickr Yahoo ID and you are set". Cool. She came back on the line and introduced me to Justin. ( on hold? 2 minutes) I explained the issue to Justin, and he asked permission to reset my password so he could try in my account himself. Sure, I can reset it when you are done. Have at it. While he was doing that, I attempted to associate my Flickr IDs. Fail. Sigh. He got the same error I did from his side on creating the sub-account. Frustrating, but a good sign I was not incompetent ;-) We talked through it, he was poking on the website while we talked and remembered another link into sub-account setup. He tried it from there. In the meantime, I was working on the Flickr issue ( he did not know this)and got to where I could get a " your Flickr ID is already associated with this Yahoo ID- do you want to use that?" message and it failed to associate the ATT. I had the sneaking suspicion this was a one to one and not a one to many association... He completed the form from the other angle ( remembering most of the data and only needed a couple of prompts, I might add) and got a difference error message. This one made sense. We needed a different ID. Picked, form filled.. correctly created. He entered a bug report for the bad error message on the other page and noted they needed to be linked to the same code, not split. I asked him about the Flickr ID issue. He said the feature was just released 2 weeks ago, so he was uncertain. Would I be willing to walk him through? Sure. We got to the Flickr log in point and he asked if I could log into Flickr, temp reset my password and let him use that to try it. OK. Again, I can reset the password when we finish the call and you never know any of my personal password info. He got to the same error I did. I explained to him that I was a legacy Flickr user (pre- Yahoo) and when Yahoo bought them, I had to link my Flickr ID to a Yahoo ID. So, my Yahoo ID was already associated with something.. how do I associate my ATT id into the mix as well? I did NOT want another Flickr account- something the system was more than willing to do for me. He poked around some more. While he was poking, I decided to set up gmail. Rather than searching the website for the pop info, I just asked Justin. Without blinking or stopping his search for ideas on the Flickr issue, he told me. Authentication failed. "Did you use your whole email as your ID?" he asked me. Oh, no- just the ID. "Do I need to use the whole thing?" "Yep" "OK". sure enough.. success. "what about transferring between Yahoo IDs?" He inquired. "Well, I have done it", I replied,"but how does that help with the att.net ID?" "That IS a Yahoo ID as well..." Ah ha, that was the piece of info I was missing to make some sense. Attempted and Voila! Not only could I log into Flickr as my new ATT identity, but 2 remote control button presses and 15 seconds later.. there were my pictures on my TV!! Coolness.
He asked permission to document the case and I talked with him for another 4 minutes as we worked through wordings and explanations of the problem and solution and made suggestions for changes to the sign up process so that other legacy Flickr users are directed to the correct steps and do not have to get the right answer from Tech Support. I was out of issues, we parted ways.

We are dealing with technology here. I do not expect it to be perfect or without bugs. I help create technology, I know how messy it can get. But the win? Short Short on hold queue times, talked to real people fast, who listened to me carefully and quickly escalated when needed. Once I got escalated, I got an intelligent human who was a good troubleshooter AND could multi-task with me. I am hooked. This is what it takes to create a satisfied customer.

And Justin's boss? In case you are reading this? Give him a raise.

5 comments:

  1. Good for you. You voted with your checkbook! Glad your installation went as you had hoped. Glad you got through to customer service easily. Enjoy the honeymoon. And be sure to post every little thing that AT&T does wrong in the same manner you did with your Comcast rants. Put it on your blog. Put it on Consumerist. Put it on Twitter. And consider changing your handle from RoguePuppet to Schadenfreude. Sounds like it best suits your sad personality.

    ReplyDelete
  2. First off, that sounds a lot like my experience with AT&T - we had a problem getting my AT&T account synced up with my new service, the tech called support, and they figured out the problem in a few minutes. All of my other dealings with them have been like yours - polite, ask if it's OK to hold, willing to walk through steps with you.

    The only issue I've had with this whole change over was when the tech was here to switch the phone over forgot to tell me that he was going to have to take down the DSL/U-verse service. He apologized when I asked about it, and asked for warning if it happened again, which I got.

    You got SageTV working with it? We didn't even try, since the internal DVR isn't too bad. We're using Sage to play things I download.

    And WTF is up with that anon comment? Some Comcast-lover with his panties in a wad? FFS, why?

    ReplyDelete
  3. @datagoddess have not gotten sageTv working yet. used to use sage with only the few channels built into the Hauppauge! receiver, as I did not have an extra tuner box here. ( AT&T gives me 3 for free, why not try it out?)
    I did dink around and get WinTV (player and direct capture software that came with the Hauppauge! hardware) working with a composite feed.. not a coaxial cable feed). This is just play through, not able to have software change channels and record.. but means i can turn the computer into a tv late at night if I want.

    The theoretical advantage with Sage is that we have the client/server licenses.. so the server can record and other computers can play back... including laptops that are traveling... since we are going to be spending many weekends in bloomington next fall it would be cool to be able to record fun stuff for the boys and watch back late at night, or on rainy days.

    ReplyDelete
  4. @Anonymous: I don't think you used the word "Schadenfreude" right. In your zeal to crap on yourself, you must have gotten overexcited and used a word that was too big for you. You can probably try again tomorrow but I wouldn't.

    ReplyDelete